FC2ブログ
  1. 無料アクセス解析

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

【統合開発環境】試行錯誤

Pyscripterの開発ホームのサイト(英語)
http://pyscripter.googlepages.com/
をきちんと見回してみると
「SupportPython3.0」という文字が見つかったので
そこを含めてもう少し詳しくみてみる。

畜生、英語だ。

足らない読解力で超意訳すると
・「最新verはPythoin2.6と3.0に対応しています」
・「Pythoin3.0対応部分は壊れています」
・「鋭意修正中です」
という感じのよう。

------抜粋-------------------------------------------------
History: v 1.9.9.2
Changes since the last official release:
-----------------------------------------------------------
Python 2.6 and 3.0 support
-----------------------------------------------------------
Update:
Python 3.0 support is currently broken.
Fixing it is a high priority issue.
--------------------------------そんな感じでしょ?----------

近いうちに使えるものがリリースされそうなので
それが分かっただけでもよしとしよう。


じゃあ対応しようとする動きは割と敏捷性高くきているのかと
昨日試してダメだった
プレアデスのall-in-one-python(Eclipse+プラグインを同梱したもの)

今度は
Eclipseと最新Pydevを別々に、
各々最新リリースをインストールしてみようとしてやってみた。

昨日使ったプレアデスが
よくみたら一個前のエウロパバージョンだったので
最新のガニメデプレアデスの方に変えてみる。
あえてJavaの方を使用。

EclipseのVer自体はあまり関係ないだろうけど。
で、手動でPydevのリモートインストールを掛けてみる。

どうでもいいが
PleiadesAllInOneEcripseの起動ロゴは
無駄にかっこよくカスタマイズされているなあ。

やっぱりインタプリタのパスを通そうとすると怒られた。
エウロパのときと同じところでのエラーなので、
AllInOnePythonにもきちんと最新のPydevが入っていたようだ。
よく考えればリモートインストールだから当たり前か。ばか。


プログラミングなんてほとんどやってませんが
その中でも一応使い慣れているのがEclipseなので
PyscripterかEclipse+Pydevかの二択は変わらないと思う。
あー。
でもGUIアプリーってなると
wxWidgetsとかの方がいいのかしら。
前にいじってた頃はデフォルトで入ってるからTkinterつかってたけど。
3.0から使うときはTkinterからtkinterに変わったらしいですね。

当面はIDLEか。
IDLEってキーワード補完機能、前からあったっけ?
補完というより一覧出すだけみたいですけど、最近追加されたのかな。
お陰で前ほど苦じゃないな。
どういう意図で付けられたのか図りかねる命名も結構好き。
STOP!アイドリング!

メモ帳でも作りながらtkinter覚えよう。

この記事へのコメント

コメントをお寄せ下さい

(コメント編集・削除に必要)
(管理者にだけ表示を許可する)

トラックバック

この記事のトラックバックURL
http://monostation.blog112.fc2.com/tb.php/1382-00d2228d

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。